convert to triangles on export


Forgive any silly questions (that I don't yet recognize as silly). My basic problem is that after importing an stl, making modifications, and then using this plugin to export  to an stl, I get complaints from slic3r 0.7.1 (which turns it into gcode for a 3d printer) about the object not being "manifold". I suspect this has to do with adding a circle to the bottom of the imported structure and extruding it. My guess is that the extruded circle is not composed purely of triangles.


Here's how I got here:

  • I took this center hub ( which is a part of
  • I imported the stl into sketchup 8 using jf_stl_importer.rb (
  • then I added a 2mm "raft" to the bottom of the structure.
  • then I exported from sketchup to stl using this plugin.
  • and then used slic3r to generate gcode. slic3r 0.7.1 says "the input file is not manifold", which is probably because the structure generated by sketchup is a polygon, and not a collection of triangles. Or that's my guess.

Can you point me at a a general approach to avoid this problem in the exported stl? Thanks in advance.


Non-manifold STLs

Hi Todd,

Good question - sometimes the STLs exported from Sketchup are non manifold - usually because there are holes in the mesh (possibly due to rounding errors in Sketchup).

What you can try is the manifold plugin to fix the mesh

Link: Sketchup manifold plugin

Or I sometimes use the Meshlab program to fix the STL meshes after exporting them from Sketchup.

The root of the problem may be the size of the object is at the limit of Sketchup's precision - try making it larger and see if the problem is still there or try altering Sketchup's  precision settings (I can't remember where exactly this setting is).